summaryrefslogtreecommitdiff
path: root/rhnop-server/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'rhnop-server/debian/rules')
-rwxr-xr-xrhnop-server/debian/rules68
1 files changed, 0 insertions, 68 deletions
diff --git a/rhnop-server/debian/rules b/rhnop-server/debian/rules
deleted file mode 100755
index ac5d9fc..0000000
--- a/rhnop-server/debian/rules
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- ./configure --prefix=/usr --sysconfdir=/etc
- touch configure-stamp
-
-build: build-stamp
-
-build-stamp: configure-stamp
- dh_testdir
- $(MAKE)
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
- $(MAKE) distclean
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_installdirs
- $(MAKE) DESTDIR=$(CURDIR)/debian/rhnop-server install
- mkdir -p $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/log
- ln -s /var/run/sv.rhnop-server/ $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/supervise
- cp $(CURDIR)/debian/rhnop-server.runit $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/run
- ln -s /var/run/sv.rhnop-server.log/ $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/log/supervise
- cp $(CURDIR)/debian/rhnop-server.runit.log $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/log/run
-
-# Build architecture-independent files here.
-binary-indep: install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: install
- dh_testdir
- dh_testroot
- dh_installdocs
- dh_installchangelogs
- dh_installexamples
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- chmod 640 debian/rhnop-server/etc/rhnop/nopsyncd.conf
- chmod 755 debian/rhnop-server/etc/sv/rhnop-server/run
- chmod 755 debian/rhnop-server/etc/sv/rhnop-server/log/run
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure