summaryrefslogtreecommitdiff
path: root/rhnop-client/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'rhnop-client/debian/rules')
-rwxr-xr-xrhnop-client/debian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/rhnop-client/debian/rules b/rhnop-client/debian/rules
index 63f5fdd..ef73f66 100755
--- a/rhnop-client/debian/rules
+++ b/rhnop-client/debian/rules
@@ -44,6 +44,11 @@ install: build
cp $(CURDIR)/debian/rhnop-client.standby.runit $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.standby/run
ln -s /var/run/sv.rhnop-client.standby.log/ $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.standby/log/supervise
cp $(CURDIR)/debian/rhnop-client.standby.runit.log $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.standby/log/run
+ mkdir -p $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.state/log
+ ln -s /var/run/sv.rhnop-client.state/ $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.state/supervise
+ cp $(CURDIR)/debian/rhnop-client.state.runit $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.state/run
+ ln -s /var/run/sv.rhnop-client.state.log/ $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.state/log/supervise
+ cp $(CURDIR)/debian/rhnop-client.state.runit.log $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.state/log/run
# Build architecture-independent files here.
binary-indep: install
@@ -61,10 +66,13 @@ binary-arch: install
dh_compress
dh_fixperms
chmod 640 debian/rhnop-client/etc/rhnop/nopcollectd.*.conf
+ chmod 640 debian/rhnop-client/etc/rhnop/nopsysstated.conf
chmod 755 debian/rhnop-client/etc/sv/rhnop-client.master/run
chmod 755 debian/rhnop-client/etc/sv/rhnop-client.master/log/run
chmod 755 debian/rhnop-client/etc/sv/rhnop-client.standby/run
chmod 755 debian/rhnop-client/etc/sv/rhnop-client.standby/log/run
+ chmod 755 debian/rhnop-client/etc/sv/rhnop-client.state/run
+ chmod 755 debian/rhnop-client/etc/sv/rhnop-client.state/log/run
dh_installdeb
dh_shlibdeps
dh_gencontrol