summaryrefslogtreecommitdiff
path: root/rhnop-server/debian
diff options
context:
space:
mode:
authorChristian Pointner <equinox@helsinki.at>2011-03-30 03:13:46 (GMT)
committerChristian Pointner <equinox@helsinki.at>2011-03-30 03:13:46 (GMT)
commit6035ed149c9f8fa272a92a65ca20bab06c474b2a (patch)
treec20d20342783f856d1ca1713e0612ac4906de275 /rhnop-server/debian
parentb79e5c9fa899514501df13868717641987750fac (diff)
fixed permission problems with config file
Diffstat (limited to 'rhnop-server/debian')
-rwxr-xr-xrhnop-server/debian/postinst2
-rwxr-xr-xrhnop-server/debian/rules1
2 files changed, 2 insertions, 1 deletions
diff --git a/rhnop-server/debian/postinst b/rhnop-server/debian/postinst
index b3b5815..4b5c141 100755
--- a/rhnop-server/debian/postinst
+++ b/rhnop-server/debian/postinst
@@ -5,5 +5,5 @@ set -e
if [ "$1" = "configure" ]; then
adduser --quiet --system --group --no-create-home --home /var/run/rhnop rhnop
- chown rhnop /etc/rhnop/nopsyncd.conf
+ chgrp rhnop /etc/rhnop/nopsyncd.conf
fi
diff --git a/rhnop-server/debian/rules b/rhnop-server/debian/rules
index 489184b..83983e1 100755
--- a/rhnop-server/debian/rules
+++ b/rhnop-server/debian/rules
@@ -50,6 +50,7 @@ binary-arch: install
dh_strip
dh_compress
dh_fixperms
+ chmod 640 debian/rhnop-server/etc/rhnop/nopsyncd.conf
dh_installdeb
dh_shlibdeps
dh_gencontrol