summaryrefslogtreecommitdiff
path: root/rhnop-server/debian/rules
diff options
context:
space:
mode:
authorChristian Pointner <equinox@helsinki.at>2011-04-02 16:03:14 (GMT)
committerChristian Pointner <equinox@helsinki.at>2011-04-02 16:03:14 (GMT)
commit96889f1baf748b33f65398c79c03b439eaa0f3ef (patch)
tree7a6941dc54ca23997f4b3504fcd3882ccd2a8a9e /rhnop-server/debian/rules
parent5524ae404ffb897ca60162819502e4a9bd7d9599 (diff)
fixed runit script
added log service to runit switched to microseconds for timestamps
Diffstat (limited to 'rhnop-server/debian/rules')
-rwxr-xr-xrhnop-server/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/rhnop-server/debian/rules b/rhnop-server/debian/rules
index 29cb020..ac5d9fc 100755
--- a/rhnop-server/debian/rules
+++ b/rhnop-server/debian/rules
@@ -34,9 +34,11 @@ install: build
dh_testroot
dh_installdirs
$(MAKE) DESTDIR=$(CURDIR)/debian/rhnop-server install
- mkdir -p $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server
+ mkdir -p $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/log
ln -s /var/run/sv.rhnop-server/ $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/supervise
cp $(CURDIR)/debian/rhnop-server.runit $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/run
+ ln -s /var/run/sv.rhnop-server.log/ $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/log/supervise
+ cp $(CURDIR)/debian/rhnop-server.runit.log $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/log/run
# Build architecture-independent files here.
binary-indep: install
@@ -55,6 +57,7 @@ binary-arch: install
dh_fixperms
chmod 640 debian/rhnop-server/etc/rhnop/nopsyncd.conf
chmod 755 debian/rhnop-server/etc/sv/rhnop-server/run
+ chmod 755 debian/rhnop-server/etc/sv/rhnop-server/log/run
dh_installdeb
dh_shlibdeps
dh_gencontrol