summaryrefslogtreecommitdiff
path: root/rhnop-client/debian/rules
diff options
context:
space:
mode:
authorChristian Pointner <equinox@helsinki.at>2011-04-05 00:40:49 (GMT)
committerChristian Pointner <equinox@helsinki.at>2011-04-05 00:40:49 (GMT)
commit688222650cdfb2d08c5a132c470c14e384a1ee3e (patch)
tree732dc3f9a616993fc11a7872161dcc72682bcb65 /rhnop-client/debian/rules
parent20d8bb7742942cd54d6ff143d0c65e957655d398 (diff)
added inital debian package
Diffstat (limited to 'rhnop-client/debian/rules')
-rwxr-xr-xrhnop-client/debian/rules75
1 files changed, 75 insertions, 0 deletions
diff --git a/rhnop-client/debian/rules b/rhnop-client/debian/rules
new file mode 100755
index 0000000..63f5fdd
--- /dev/null
+++ b/rhnop-client/debian/rules
@@ -0,0 +1,75 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ ./configure --prefix=/usr --sysconfdir=/etc
+ touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+ $(MAKE)
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ $(MAKE) distclean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_installdirs
+ $(MAKE) DESTDIR=$(CURDIR)/debian/rhnop-client install
+ mkdir -p $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.master/log
+ ln -s /var/run/sv.rhnop-client.master/ $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.master/supervise
+ cp $(CURDIR)/debian/rhnop-client.master.runit $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.master/run
+ ln -s /var/run/sv.rhnop-client.master.log/ $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.master/log/supervise
+ cp $(CURDIR)/debian/rhnop-client.master.runit.log $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.master/log/run
+ mkdir -p $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.standby/log
+ ln -s /var/run/sv.rhnop-client.standby/ $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.standby/supervise
+ cp $(CURDIR)/debian/rhnop-client.standby.runit $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.standby/run
+ ln -s /var/run/sv.rhnop-client.standby.log/ $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.standby/log/supervise
+ cp $(CURDIR)/debian/rhnop-client.standby.runit.log $(CURDIR)/debian/rhnop-client/etc/sv/rhnop-client.standby/log/run
+
+# Build architecture-independent files here.
+binary-indep: install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installchangelogs
+ dh_installexamples
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ chmod 640 debian/rhnop-client/etc/rhnop/nopcollectd.*.conf
+ chmod 755 debian/rhnop-client/etc/sv/rhnop-client.master/run
+ chmod 755 debian/rhnop-client/etc/sv/rhnop-client.master/log/run
+ chmod 755 debian/rhnop-client/etc/sv/rhnop-client.standby/run
+ chmod 755 debian/rhnop-client/etc/sv/rhnop-client.standby/log/run
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure