summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Pointner <equinox@helsinki.at>2015-05-14 13:38:17 (GMT)
committerChristian Pointner <equinox@helsinki.at>2015-05-14 13:38:17 (GMT)
commit3973788d772b7eb95284222a1ef9a7c9a00dd974 (patch)
treecd73e5f3098aa07aa918ecac78f770df4a69cef9 /debian/rules
parent0e39f791c21637176ec9b13dae1d2f2aff6b3383 (diff)
updated to package 0.12 with systemd unit files
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 83b194e..e09f048 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,12 @@
#!/usr/bin/make -f
%:
- dh $@ --sourcedirectory=src
+ dh $@ --with=systemd --sourcedirectory=src
override_dh_auto_configure:
dh_auto_configure -- --ebuild-compat
+
+override_dh_systemd_enable:
+ dh_systemd_enable --name=nopsyncd nopsyncd.service
+ dh_systemd_enable --name=nopsysstated nopsysstated.service
+ dh_systemd_enable --name=nopcollectd-master nopcollectd-master.service
+ dh_systemd_enable --name=nopcollectd-standby nopcollectd-standby.service