summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/rhctl/Makefile2
-rwxr-xr-xopenwrt/rhctl/files/heartbeatclient.init14
-rw-r--r--openwrt/rhctl/files/rhctl.config2
3 files changed, 16 insertions, 2 deletions
diff --git a/openwrt/rhctl/Makefile b/openwrt/rhctl/Makefile
index 7071bb1..5a88216 100644
--- a/openwrt/rhctl/Makefile
+++ b/openwrt/rhctl/Makefile
@@ -18,7 +18,7 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://localhost/
-PKG_MD5SUM:=eb7c44c6c95da63480440799d3f72041
+PKG_MD5SUM:=a09815ee33dd76f43c277ca80a770073
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
diff --git a/openwrt/rhctl/files/heartbeatclient.init b/openwrt/rhctl/files/heartbeatclient.init
index 97f59ce..b201c5e 100755
--- a/openwrt/rhctl/files/heartbeatclient.init
+++ b/openwrt/rhctl/files/heartbeatclient.init
@@ -54,3 +54,17 @@ stop() {
fi
echo "."
}
+
+reset() {
+ echo -n "$DESC: Restarting timeout"
+ if [ -f $PIDFILE ]; then
+ kill -HUP `cat $PIDFILE` > /dev/null 2>&1
+ echo -n " (Ok)"
+ else
+ echo -n " (not running)"
+ fi
+ echo "."
+}
+
+EXTRA_COMMANDS=reset
+EXTRA_HELP=" reset Restart timeout and switch back to master"
diff --git a/openwrt/rhctl/files/rhctl.config b/openwrt/rhctl/files/rhctl.config
index 7d14e51..3245618 100644
--- a/openwrt/rhctl/files/rhctl.config
+++ b/openwrt/rhctl/files/rhctl.config
@@ -30,4 +30,4 @@ config 'heartbeatclient'
option command_sock '/var/run/rhctl/switchctl.sock'
option baudrate '38400'
option device '/dev/ttyHeartbeat'
-
+ option timeout '50'