summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorChristian Pointner <equinox@helsinki.at>2010-01-10 12:31:34 (GMT)
committerChristian Pointner <equinox@helsinki.at>2010-01-10 12:31:34 (GMT)
commit6218a84102038f95683cffbbde9fcf9fff8d2827 (patch)
tree61ff60f126451ef14a8122abe0ba04102252b1a4 /openwrt
parent0e13f8198ac1edc6f9b3a62492425cbdfd8669e4 (diff)
improved termios settings
fixed length check at write fixed output at log
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/rhctl/Makefile2
-rw-r--r--openwrt/rhctl/files/rhctl.config7
2 files changed, 6 insertions, 3 deletions
diff --git a/openwrt/rhctl/Makefile b/openwrt/rhctl/Makefile
index 84fc2e3..cc2acac 100644
--- a/openwrt/rhctl/Makefile
+++ b/openwrt/rhctl/Makefile
@@ -18,7 +18,7 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://localhost/
-PKG_MD5SUM:=646e9d1439cc9c23d3cb64773b34c513
+PKG_MD5SUM:=d406052350d01799bcf69ea2c575a436
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
diff --git a/openwrt/rhctl/files/rhctl.config b/openwrt/rhctl/files/rhctl.config
index 3b4874e..7d14e51 100644
--- a/openwrt/rhctl/files/rhctl.config
+++ b/openwrt/rhctl/files/rhctl.config
@@ -1,4 +1,5 @@
config 'switchctl'
+ option log 'syslog:5,switchctl,daemon'
option command_sock '/var/run/rhctl/switchctl.sock'
option baudrate '19200'
option device '/dev/audioswitch'
@@ -9,7 +10,7 @@ config 'switchctl'
config 'serialclient'
# option disabled 1
option name 'master'
- option log 'syslog:3,serialclient-master,daemon'
+ option log 'syslog:5,serialclient-master,daemon'
option command_sock '/var/run/rhctl/switchctl.sock'
option baudrate '38400'
option device '/dev/ttyMaster'
@@ -18,13 +19,15 @@ config 'serialclient'
config 'serialclient'
# option disabled 1
option name 'standby'
- option log 'syslog:3,serialclient-standby,daemon'
+ option log 'syslog:5,serialclient-standby,daemon'
option command_sock '/var/run/rhctl/switchctl.sock'
option baudrate '38400'
option device '/dev/ttyStandby'
option type 'standby'
config 'heartbeatclient'
+ option log 'syslog:5,heartbeatclient,daemon'
option command_sock '/var/run/rhctl/switchctl.sock'
option baudrate '38400'
option device '/dev/ttyHeartbeat'
+