summaryrefslogtreecommitdiff
path: root/openwrt/rhctl/Makefile
diff options
context:
space:
mode:
authorChristian Pointner <equinox@helsinki.at>2018-11-07 11:01:29 (GMT)
committerChristian Pointner <equinox@helsinki.at>2018-11-07 11:01:29 (GMT)
commitfb90864a19f2b834ce8ba5773dc0a6aed9e0f11e (patch)
treedc91519fd928d6bb30bc57961aedb883aa941fb3 /openwrt/rhctl/Makefile
parent6c552b607e8c1a175ae26e90b9637836dc571ee9 (diff)
updated openwrt packaging
Diffstat (limited to 'openwrt/rhctl/Makefile')
-rw-r--r--openwrt/rhctl/Makefile54
1 files changed, 16 insertions, 38 deletions
diff --git a/openwrt/rhctl/Makefile b/openwrt/rhctl/Makefile
index ada885d..b126c32 100644
--- a/openwrt/rhctl/Makefile
+++ b/openwrt/rhctl/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2013-2015 Christian Pointner,
+# Copyright (C) 2016 Christian Pointner,
# <equinox@helsinki.at>
#
# This is free software, licensed under the GNU General Public License v2.
@@ -12,7 +12,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rhctl
-PKG_VERSION:=2015-07-26
+PKG_VERSION:=2017-01-11
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
@@ -26,62 +26,40 @@ include $(INCLUDE_DIR)/package.mk
define Package/rhctl
SECTION:=utils
CATEGORY:=Utilities
- TITLE:=Radio Helsinki audioswitch control tools
+ TITLE:=Radio Helsinki audioswitch control daemon
URL:=http://www.helsinki.at
MAINTAINER:=Christian Pointner <equinox@helsinki.at>
- DEPENDS:=+liblua +luasocket +hotplug2 +msmtp
+ DEPENDS:=+curl
endef
define Package/rhctl/conffiles
-/etc/rhctl/switchctl.conf
+/etc/rhctl/config.toml
endef
define Package/rhctl/description
-rhctl is a collection of daemons and tools intended to control the
- main audio switch of Radio Helsinki.
+rhctl is a small daemon to control the main audioswitch at Radio Helsinki.
+ The daemon can work standalone but may be controlled via telnet. It also
+ exports status updates via websockets.
endef
define Build/Configure
- (cd $(PKG_BUILD_DIR)/src; \
- touch include.mk; \
- )
endef
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)/src \
- $(TARGET_CONFIGURE_OPTS) \
- TARGET=Linux \
- CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
- LDFLAGS="$(TARGET_LDFLAGS) -ldl -lm -lcrypt" \
- LUA_LDFLAGS="-llua"
- $(STRIP) $(PKG_BUILD_DIR)/src/switchctl
- $(STRIP) $(PKG_BUILD_DIR)/src/serialclient
- $(STRIP) $(PKG_BUILD_DIR)/src/stdioclient
- $(STRIP) $(PKG_BUILD_DIR)/src/heartbeatclient
- $(STRIP) $(PKG_BUILD_DIR)/src/luaclient
+ export GOROOT=/opt/go
+ $(MAKE) -C $(PKG_BUILD_DIR)/ build-alix
endef
define Package/rhctl/install
$(INSTALL_DIR) $(1)/etc/rhctl
- $(INSTALL_DATA) ./files/switchctl.conf $(1)/etc/rhctl/
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_DATA) ./files/rhctl.config $(1)/etc/config/rhctl
+ $(INSTALL_DATA) ./files/config.toml $(1)/etc/rhctl/
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/switchctl $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/serialclient $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/stdioclient $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/heartbeatclient $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/luaclient $(1)/usr/bin/
- $(INSTALL_BIN) ./files/rhctlsh $(1)/usr/bin/
- $(INSTALL_DIR) $(1)/usr/share/rhctl
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/src/*.lua $(1)/usr/share/rhctl/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/linux_386/rhctl $(1)/usr/bin/
$(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/switchctl.init $(1)/etc/init.d/switchctl
- $(INSTALL_BIN) ./files/serialclient.init $(1)/etc/init.d/serialclient
- $(INSTALL_BIN) ./files/heartbeatclient.init $(1)/etc/init.d/heartbeatclient
- $(INSTALL_BIN) ./files/luaclient.init $(1)/etc/init.d/luaclient
- $(INSTALL_DIR) $(1)/etc/hotplug.d/usb
- $(INSTALL_DATA) ./files/rhctl-usbserial.hotplug $(1)/etc/hotplug.d/usb/20-rhctl-usbserial
+ $(INSTALL_BIN) ./files/rhctl.init $(1)/etc/init.d/rhctl
+ $(INSTALL_DIR) $(1)/usr/lib/check_mk_agent/plugins
+ $(INSTALL_BIN) ./files/rhctl.check_mk $(1)/usr/lib/check_mk_agent/plugins/rhctl
+
endef
$(eval $(call BuildPackage,rhctl))