summaryrefslogtreecommitdiff
path: root/snd-pcxhr/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'snd-pcxhr/debian/rules')
-rwxr-xr-xsnd-pcxhr/debian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/snd-pcxhr/debian/rules b/snd-pcxhr/debian/rules
new file mode 100755
index 0000000..69bc5cc
--- /dev/null
+++ b/snd-pcxhr/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/pkg-info.mk
+
+%:
+ dh $@ --with dkms
+
+override_dh_auto_install:
+ install -d $$(pwd)/debian/tmp/usr/src/snd-pcxhr-$(DEB_VERSION_UPSTREAM)/
+ install $$(pwd)/src/Makefile $$(pwd)/src/*.c $$(pwd)/src/*.h $$(pwd)/debian/tmp/usr/src/snd-pcxhr-$(DEB_VERSION_UPSTREAM)/
+ install -d $$(pwd)/debian/tmp/lib/firmware/pcxhr/
+ install $$(pwd)/src/firmware/* $$(pwd)/debian/tmp/lib/firmware/pcxhr/
+
+override_dh_auto_configure:
+override_dh_auto_build:
+override_dh_auto_test:
+override_dh_auto_install:
+override_dh_auto_clean: