summaryrefslogtreecommitdiff
path: root/snd-alpx/debian/rules
diff options
context:
space:
mode:
authorChristian Pointner <equinox@helsinki.at>2024-05-10 18:41:35 (GMT)
committerChristian Pointner <equinox@helsinki.at>2024-05-10 18:43:29 (GMT)
commitcc4badffe0e02d159c21eb90ea080a6a2f90cb4b (patch)
tree5f0836ae96fc78c065093945a61d8a3994fe5434 /snd-alpx/debian/rules
parent627f7d488817e308d6f3a92fd9a877723ac7ae1d (diff)
add initial debian packaging files
Diffstat (limited to 'snd-alpx/debian/rules')
-rwxr-xr-xsnd-alpx/debian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/snd-alpx/debian/rules b/snd-alpx/debian/rules
new file mode 100755
index 0000000..0709c94
--- /dev/null
+++ b/snd-alpx/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/pkg-info.mk
+
+%:
+ dh $@ --with dkms
+
+override_dh_install:
+ dh_install * usr/src/snd-alpx-$(DEB_VERSION_UPSTREAM)/
+
+override_dh_dkms:
+ dh_dkms -V $(DEB_VERSION_UPSTREAM) -- dkms.conf
+
+override_dh_auto_configure:
+override_dh_auto_build:
+override_dh_auto_test:
+override_dh_auto_install:
+override_dh_auto_clean: