summaryrefslogtreecommitdiff
path: root/openwrt/check_mk_agent/Makefile
diff options
context:
space:
mode:
authorChristian Pointner <equinox@helsinki.at>2016-11-24 22:04:16 (GMT)
committerChristian Pointner <equinox@helsinki.at>2016-11-24 22:04:16 (GMT)
commit091f0037abe7ac3144199956d943c1537a95cdd9 (patch)
tree798738e6e5d50fb2e34b4b6eab24cf7c2357ad27 /openwrt/check_mk_agent/Makefile
parent6e9ad0a47bfb642ee032b907c79364055a655b40 (diff)
added check-mk agent package for openwrt
Diffstat (limited to 'openwrt/check_mk_agent/Makefile')
-rw-r--r--openwrt/check_mk_agent/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/openwrt/check_mk_agent/Makefile b/openwrt/check_mk_agent/Makefile
new file mode 100644
index 0000000..6d17910
--- /dev/null
+++ b/openwrt/check_mk_agent/Makefile
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2016 Christian Pointner,
+# <equinox@helsinki.at>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# This Makefile builds check_mk_agent Package for OpenWRT
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=check_mk_agent
+PKG_VERSION:=2016-11-24
+PKG_RELEASE:=1
+
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/check_mk_agent
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=check-mk agent
+ URL:=http://www.helsinki.at
+ MAINTAINER:=Christian Pointner <equinox@helsinki.at>
+ DEPENDS:=+xinetd
+endef
+
+define Package/check_mk_agent/conffiles
+/etc/xinetd.d/check_mk
+endef
+
+define Package/check_mk_agent/description
+Agent for the check-mk monitoring service.
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/check_mk_agent/install
+ $(INSTALL_DIR) $(1)/usr/lib/check_mk_agent/local
+ $(INSTALL_DIR) $(1)/usr/lib/check_mk_agent/plugins
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) ./files/check_mk_agent $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/etc/xinetd.d/
+ $(INSTALL_BIN) ./files/check_mk.xinetd $(1)/etc/xinetd.d/check_mk
+endef
+
+$(eval $(call BuildPackage,check_mk_agent))