From 530792d9e36bc13ca5edfd5d9e8edf4a5e21ade2 Mon Sep 17 00:00:00 2001
From: Christian Pointner <equinox@helsinki.at>
Date: Tue, 11 Mar 2014 15:43:26 +0000
Subject: fix for utf-8 patch


diff --git a/rhnop-client/db.lua b/rhnop-client/db.lua
index bf27bef..4c0a107 100644
--- a/rhnop-client/db.lua
+++ b/rhnop-client/db.lua
@@ -54,7 +54,7 @@ function db.init(db, user, pwd, host, port, table)
       return nil, err
    end
 
-   local ret, err = self.con:execute("SET CHARACTER SET utf8")
+   local ret, err = mydb.con:execute("SET CHARACTER SET utf8")
    if ret == nil then
       return nil, err
    end
diff --git a/rhnop-client/debian/changelog b/rhnop-client/debian/changelog
index 2b7ad70..19e9bb3 100644
--- a/rhnop-client/debian/changelog
+++ b/rhnop-client/debian/changelog
@@ -1,4 +1,10 @@
-rhnop-client (0.3) UNRELEASED; urgency=low
+rhnop-client (0.4) UNRELEASED; urgency=low
+
+  * forcing utf-8
+
+ -- Christian Pointner <equinox@helsinki.at>  Tue, 11 Mar 2014 16:01:08 +0100
+
+rhnop-client (0.3) unstable; urgency=low
 
   * fixed error due to new luasql library version
 
-- 
cgit v0.10.2