summaryrefslogtreecommitdiff
path: root/rhnop-server/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'rhnop-server/debian/rules')
-rwxr-xr-xrhnop-server/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/rhnop-server/debian/rules b/rhnop-server/debian/rules
index 29cb020..ac5d9fc 100755
--- a/rhnop-server/debian/rules
+++ b/rhnop-server/debian/rules
@@ -34,9 +34,11 @@ install: build
dh_testroot
dh_installdirs
$(MAKE) DESTDIR=$(CURDIR)/debian/rhnop-server install
- mkdir -p $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server
+ mkdir -p $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/log
ln -s /var/run/sv.rhnop-server/ $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/supervise
cp $(CURDIR)/debian/rhnop-server.runit $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/run
+ ln -s /var/run/sv.rhnop-server.log/ $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/log/supervise
+ cp $(CURDIR)/debian/rhnop-server.runit.log $(CURDIR)/debian/rhnop-server/etc/sv/rhnop-server/log/run
# Build architecture-independent files here.
binary-indep: install
@@ -55,6 +57,7 @@ binary-arch: install
dh_fixperms
chmod 640 debian/rhnop-server/etc/rhnop/nopsyncd.conf
chmod 755 debian/rhnop-server/etc/sv/rhnop-server/run
+ chmod 755 debian/rhnop-server/etc/sv/rhnop-server/log/run
dh_installdeb
dh_shlibdeps
dh_gencontrol