From c9635c2b0f74a639f33460cb933399684ef868ab Mon Sep 17 00:00:00 2001
From: Christian Pointner <equinox@helsinki.at>
Date: Tue, 13 Apr 2010 12:36:54 +0000
Subject: fixed ssh parameters


diff --git a/rhimport.pm b/rhimport.pm
index dc08479..35f9f53 100644
--- a/rhimport.pm
+++ b/rhimport.pm
@@ -193,7 +193,7 @@ sub import_single
 sub scp_put_file 
 {
   my ($file) = @_;
-  my @cmd = ( 'scp', '-prqB' , '-i', $ssh_key_file, $file, "$ssh_user\@$ssh_host:$ssh_dir/" );
+  my @cmd = ( 'scp', '-prqB', '-i', $ssh_key_file, $file, "$ssh_user\@$ssh_host:$ssh_dir/" );
   my ($reader, $writer, $error ) = ( new IO::Handle, new IO::Handle, new IO::Handle );
   $writer->autoflush(1);
   local $SIG{CHLD} = 'DEFAULT';
@@ -209,7 +209,7 @@ sub scp_put_file
 sub ssh_exec_command 
 {
   my ($command) = @_;
-  my @cmd = ( 'ssh' , '-i', $ssh_key_file, "$ssh_user\@$ssh_host" , $command );
+  my @cmd = ( 'ssh' , '-q', '-o', 'BatchMode', '-i', $ssh_key_file, "$ssh_user\@$ssh_host" , $command );
   my ($reader, $writer, $error ) = ( new IO::Handle, new IO::Handle, new IO::Handle );
   $writer->autoflush(1);
   local $SIG{CHLD} = 'DEFAULT';
-- 
cgit v0.10.2