From 86e47c548b046426f18c5cf541c02f4468c43b6d Mon Sep 17 00:00:00 2001
From: Christian Pointner <equinox@helsinki.at>
Date: Fri, 3 Jun 2016 18:46:38 +0200
Subject: JSON::MaybeXS is too new ... switching to JSON::Any


diff --git a/debian/changelog b/debian/changelog
index ba8696a..ae726eb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,10 @@
-rhimport (0.3.15-47) unstable; urgency=medium
+rhimport (0.3.15-49) unstable; urgency=medium
+
+  * Perl JSON::MaybeXS is too new .. switch back to JSON::Any
+
+ -- Christian Pointner <equinox@helsinki.at>  Fri, 03 Jun 2016 18:45:24 +0200
+
+rhimport (0.3.15-48) unstable; urgency=medium
 
   * added importer for Economic Update
 
diff --git a/debian/control b/debian/control
index 8bc2b89..141d208 100644
--- a/debian/control
+++ b/debian/control
@@ -8,7 +8,7 @@ Homepage: http://www.helsinki.at/
 
 Package: rhimport
 Architecture: all
-Depends: ${misc:Depends}, adduser, perl, libdbd-mysql-perl, libgtk2-gladexml-perl, libdate-calc-perl, libdatetime-format-strptime-perl, libdatetime-format-iso8601-perl, libxml-feed-perl, libjson-maybexs-perl, liburi-perl, libwww-perl, libfile-slurp-perl, libfile-touch-perl
+Depends: ${misc:Depends}, adduser, perl, libdbd-mysql-perl, libgtk2-gladexml-perl, libdate-calc-perl, libdatetime-format-strptime-perl, libdatetime-format-iso8601-perl, libxml-feed-perl, libjson-any-perl, liburi-perl, libwww-perl, libfile-slurp-perl, libfile-touch-perl
 Description: Radio Helsinki Import Tool
  rhimport is a small tool which can be used to import media files
  into the playout system namley Rivendell.
diff --git a/rhimport.pm b/rhimport.pm
index 0e8b7f6..67e8440 100644
--- a/rhimport.pm
+++ b/rhimport.pm
@@ -37,7 +37,7 @@ use DateTime::TimeZone;
 use LWP::Simple;
 use XML::Feed;
 use URI::Fetch;
-use JSON::MaybeXS;
+use JSON::Any;
 
 my $ssh_host = "airplay";
 my $ssh_user = "rhimport";
@@ -117,7 +117,7 @@ sub fetch_parse_json
   my $json = $res->content;
   my $data;
   eval {
-    my $j = JSON::MaybeXS->new(utf8 => 0);
+    my $j = JSON::Any->new(utf8 => 0);
     $data = $j->decode($json);
     1;
   } or do {
-- 
cgit v0.10.2