From f2b45efc3aa26c360259eefcc3cc31c056d34ef5 Mon Sep 17 00:00:00 2001
From: Christian Pointner <equinox@helsinki.at>
Date: Tue, 19 Jan 2010 13:22:04 +0000
Subject: fixed build


diff --git a/options.c b/options.c
index 2169837..0042e2b 100644
--- a/options.c
+++ b/options.c
@@ -531,7 +531,8 @@ void options_print(options_t* opt)
 
 #ifdef OPT_SWITCHCTL
   printf("mode: '%s'\n", opt->mode_ == MODE_MASTER ? "master" : "standby");
-  printf("channel: '%s'\n", opt->channel_ == CHAN_MAIN ? "main" : "music");
+  printf("channel_master: '%s'\n", opt->channel_master_ == CHAN_MAIN ? "main" : "music");
+  printf("channel_standby: '%s'\n", opt->channel_standby_ == CHAN_MAIN ? "main" : "music");
   printf("conf_file: '%s'\n", opt->conf_file_);
   printf("switch_dev: '%s'\n", opt->switch_dev_);
   printf("alias_table: \n");
diff --git a/switchctl.c b/switchctl.c
index d603fc2..97202b7 100644
--- a/switchctl.c
+++ b/switchctl.c
@@ -379,7 +379,7 @@ int process_cmd_mode(const char* param, int fd, cmd_t **cmd_q, options_t* opt, c
         ch_from = "master_main";
       else if(old_mode == MODE_MASTER && opt->channel_master_ == CHAN_MUSIC)
         ch_from = "master_music";
-      else if(old_mode == MODE_STANDBY && opt->channel_standy_ == CHAN_MAIN)
+      else if(old_mode == MODE_STANDBY && opt->channel_standby_ == CHAN_MAIN)
         ch_from = "standby_main";
       else if(old_mode == MODE_STANDBY && opt->channel_standby_ == CHAN_MUSIC)
         ch_from = "standby_music";
-- 
cgit v0.10.2