From 1f9e9bbd95a4cd111fe4cf8405235339a87a3035 Mon Sep 17 00:00:00 2001
From: Christian Pointner <equinox@helsinki.at>
Date: Wed, 22 Jun 2022 13:13:59 +0200
Subject: adapt Kein Kommentar importer to new scheme


diff --git a/INFO b/INFO
index a767275..ceaba86 100644
--- a/INFO
+++ b/INFO
@@ -149,3 +149,10 @@
    Upload: am selben Tag, manchmal ein bis zwei Tage davor
    Such-Kriterium: cba:broadcastDate wenn gesetzt sonst cba:productionDate
    RH: 4wöchentlich, Woche 4, Freitag, 17:00-17:30
+
+- (kk) Kein Kommentar
+   https://cba.fro.at/podcast/kein-kommentar/feed
+   Original: 4wöchentlich Dienstag -> wird als 2 halbstündige Sendungen umgeschnittten -> 2wöchentlich Freitag (Woche 2 und 4)
+   Upload: einen Tag davor (Donnerstag mittag)
+   Such-Kriterium: cba:broadcastDate wenn gesetzt sonst cba:productionDate
+   RH: 2wöchentlich, Woche 2/4, Freitag, 16:30-17:00
diff --git a/Makefile b/Makefile
index 6f5065a..4eb88b2 100644
--- a/Makefile
+++ b/Makefile
@@ -26,7 +26,7 @@ endif
 .PHONY: clean distclean
 
 EXECUTABLE := rhautoimport
-IMPORTER := ar ba bo btl cb cr dm dn ek eu gd lr mz oi po rs ra so
+IMPORTER := ar ba bo btl cb cr dm dn ek eu gd kk lr mz oi po rs ra so
 EXECUTABLES := $(IMPORTER:%=$(EXECUTABLE)-%)
 
 all: $(EXECUTABLE)
diff --git a/TODO b/TODO
index 90b27a8..4cbe217 100644
--- a/TODO
+++ b/TODO
@@ -23,10 +23,3 @@
    Such-Kriterium: ??
    RH: 4wöchentlich, Woche 4, Donnerstag, 15:00-16:00
        4wöchentlich, Woche 4, Samstag, 20:00-21:00
-
-- (kk) Kein Kommentar
-   https://cba.fro.at/podcast/kein-kommentar/feed
-   Original: 2wöchentlich Dienstag (Woche 2 und 4)
-   Upload: meistens am selben Tag..
-   Such-Kriterium: cba:broadcastDate wenn gesetzt sonst cba:productionDate
-   RH: 2wöchentlich, Woche 2/4, Freitag, 16:30-17:00
diff --git a/rhautoimport-kk b/rhautoimport-kk
index a8e790e..e91b79e 100755
--- a/rhautoimport-kk
+++ b/rhautoimport-kk
@@ -42,7 +42,7 @@ my $RD_GROUP = "keinkomm";
 my $PV_ID = '920';
 my $TITLE="Kein Kommentar";
 my $LAST_RUN = 0;
-my $upload_delay_days = 0;   # files are usally there on the same day
+my $upload_delay_days = -2;   # files are usally there one day before
 
 binmode(STDIN, ":utf8");
 binmode(STDOUT, ":utf8");
@@ -90,9 +90,7 @@ if(scalar(@allowed_dbs) != 1) {
 my $show_id = $allowed_dbs[0]->{'SHOWID'};
 my $show_title = $allowed_dbs[0]->{'SHOWTITLE'};
 
-my @broadcast_date = Date::Calc::Standard_to_Business(@import_date);
-$broadcast_date[2] = 2;
-@broadcast_date = Date::Calc::Business_to_Standard(@broadcast_date);
+my @broadcast_date = @import_date;
 print "day of latest original broadcast before next Radio Helsinki broadcast: " . Date::Calc::Date_to_Text(@broadcast_date) . "\n";
 
 if(Date::Calc::Delta_Days(@broadcast_date, @today) <= $upload_delay_days) {
-- 
cgit v0.10.2