From fc91f05b685bc480845b77b273b5072a1ef54581 Mon Sep 17 00:00:00 2001
From: Christian Pointner <equinox@helsinki.at>
Date: Thu, 16 Jul 2015 17:45:26 +0200
Subject: added importer for tierrecht


diff --git a/Makefile b/Makefile
index 0b23dc1..d4c76c8 100644
--- a/Makefile
+++ b/Makefile
@@ -55,6 +55,7 @@ install-bin:
 	$(INSTALL) -m 755 $(EXECUTABLE)-ra $(DESTDIR)$(BINDIR)
 	$(INSTALL) -m 755 $(EXECUTABLE)-sm $(DESTDIR)$(BINDIR)
 	$(INSTALL) -m 755 $(EXECUTABLE)-sv $(DESTDIR)$(BINDIR)
+	$(INSTALL) -m 755 $(EXECUTABLE)-tr $(DESTDIR)$(BINDIR)
 	$(INSTALL) -m 755 $(EXECUTABLE)-ut $(DESTDIR)$(BINDIR)
 	$(INSTALL) -m 755 $(EXECUTABLE)-zf $(DESTDIR)$(BINDIR)
 	$(INSTALL) -m 755 $(EXECUTABLE)-zffe $(DESTDIR)$(BINDIR)
@@ -73,6 +74,7 @@ install-bin:
 	@sed s#/usr/local/share/rhimport/#$(SHAREDIR)/$(EXECUTABLE)/#g -i $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-ra
 	@sed s#/usr/local/share/rhimport/#$(SHAREDIR)/$(EXECUTABLE)/#g -i $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-sm
 	@sed s#/usr/local/share/rhimport/#$(SHAREDIR)/$(EXECUTABLE)/#g -i $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-sv
+	@sed s#/usr/local/share/rhimport/#$(SHAREDIR)/$(EXECUTABLE)/#g -i $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-tr
 	@sed s#/usr/local/share/rhimport/#$(SHAREDIR)/$(EXECUTABLE)/#g -i $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-ut
 	@sed s#/usr/local/share/rhimport/#$(SHAREDIR)/$(EXECUTABLE)/#g -i $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-zf
 	@sed s#/usr/local/share/rhimport/#$(SHAREDIR)/$(EXECUTABLE)/#g -i $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-zffe
@@ -102,6 +104,7 @@ remove-bin:
 	rm -f $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-ra
 	rm -f $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-sm
 	rm -f $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-sv
+	rm -f $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-tr
 	rm -f $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-ut
 	rm -f $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-zf
 	rm -f $(DESTDIR)$(BINDIR)/$(EXECUTABLE)-zffe
diff --git a/debian/changelog b/debian/changelog
index 62e9590..13b95f5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,10 @@
-rhimport (0.3.15-39) UNRELEASED; urgency=medium
+rhimport (0.3.15-40) unstable; urgency=medium
+
+  * added importer for tierrecht
+
+ -- Christian Pointner <equinox@helsinki.at>  Thu, 16 Jul 2015 17:44:20 +0200
+
+rhimport (0.3.15-39) unstable; urgency=medium
 
   * onda info blocks certain user agent strings - added workaround
 
@@ -24,7 +30,7 @@ rhimport (0.3.15-36) unstable; urgency=low
 
 rhimport (0.3.15-35) unstable; urgency=low
 
-  * democracy now also runs during von unten 
+  * democracy now also runs during von unten
 
  -- Christian Pointner <equinox@helsinki.at>  Thu, 07 Aug 2014 14:43:56 +0200
 
diff --git a/rhimport-tr b/rhimport-tr
new file mode 100755
index 0000000..d86bdb9
--- /dev/null
+++ b/rhimport-tr
@@ -0,0 +1,189 @@
+#!/usr/bin/perl -w
+#
+#
+#  rhimport
+#
+#  Copyright (C) 2009 Christian Pointner <equinox@helsinki.at>
+#
+#  This file is part of rhimport.
+#
+#  rhimport is free software: you can redistribute it and/or modify
+#  it under the terms of the GNU General Public License as published by
+#  the Free Software Foundation, either version 3 of the License, or
+#  any later version.
+#
+#  rhimport is distributed in the hope that it will be useful,
+#  but WITHOUT ANY WARRANTY; without even the implied warranty of
+#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+#  GNU General Public License for more details.
+#
+#  You should have received a copy of the GNU General Public License
+#  along with rhimport. If not, see <http://www.gnu.org/licenses/>.
+#
+
+use strict;
+use DBI;
+use Date::Calc;
+use XML::Feed;
+use XML::Feed::Entry;
+use XML::Feed::Content;
+use XML::Feed::Enclosure;
+use File::Fetch;
+use IO::Handle;
+use IPC::Open3;
+use HTML::Entities;
+
+use lib '/usr/local/share/rhimport/';
+use rhimport;
+
+my $DBHOST = "airplay";
+my $DBUSER = "rivendell";
+my $DBPW = "lldriven";
+my $DB = "rivendell";
+
+my $STAT_FILE = $ENV{'HOME'} . "/rhimport-tr.stat";
+my $RSS_URL = "http://cba.fro.at/series/tierrechtsradio/feed?c=Kfs2IoV2Wmd";
+$XML::Feed::MULTIPLE_ENCLOSURES=1;
+my $PV_ID = '506';
+
+binmode(STDIN, ":utf8");
+binmode(STDOUT, ":utf8");
+binmode(STDERR, ":utf8");
+
+if($#ARGV >= 0 && $ARGV[0] eq 'last') {
+  print "!!!This is the last attempt, there won't be a retry on error!!!\n"
+}
+
+my $user = `/usr/bin/id -un`;
+$user =~ s/\n//;
+my $group = "tierrecht";
+
+my $dbh = DBI->connect("DBI:mysql:$DB:$DBHOST","$DBUSER","$DBPW") or die "Database Error: $DBI::errstr";
+my @allowed_dbs = rhimport::get_dropboxes($dbh, $user, $group);
+
+my $idx = 0;
+if(scalar(@allowed_dbs) != 1) {
+  print "found more or less than 1 Dropbox for this group?!\n";
+  $dbh->disconnect();
+  exit 1;
+}
+my $dropbox = $allowed_dbs[$idx]->{'PATH'};
+my $to_cart = $allowed_dbs[$idx]->{'TO_CART'};
+
+my @today = Date::Calc::Standard_to_Business(Date::Calc::Today());
+if($today[2] == 5) {
+  print "please don't run this script on fridays!\n";
+  $dbh->disconnect();
+  exit 1;
+}
+my @broadcast_day = Date::Calc::Business_to_Standard($today[0], $today[1], 5);
+if($today[2] < 5) {
+  @broadcast_day = Date::Calc::Add_Delta_Days($broadcast_day[0], $broadcast_day[1], $broadcast_day[2], -7);
+}
+my @import_date = Date::Calc::Add_Delta_Days($broadcast_day[0], $broadcast_day[1], $broadcast_day[2], 7);
+
+print "day of original broadcast: " . Date::Calc::Date_to_Text(@broadcast_day) . "\n";
+print "day of Radio Helsinki broadcast: " . Date::Calc::Date_to_Text(@import_date) . "\n";
+
+my $bd = sprintf("%04d-%02d-%02d", $broadcast_day[0], $broadcast_day[1], $broadcast_day[2]);
+my $bdfile = sprintf("^%04d%02d%02d", $broadcast_day[0], $broadcast_day[1], $broadcast_day[2]);
+
+print "looking for files from $bd in RSS Feed\n";
+print " -> $RSS_URL\n";
+
+my $feed = XML::Feed->parse(URI->new($RSS_URL))
+  or die "Error fetching feed: " . XML::Feed->errstr;
+
+my $file = "";
+my $out_file = "";
+my $i = 0;
+for my $entry ($feed->entries) {
+  $i++;
+  next unless $entry->enclosure;
+  my $j = 0;
+  for my $enclosure($entry->enclosure) {
+    $j++;
+    if($enclosure->type eq "audio/mpeg" || $enclosure->type eq "audio/ogg") {
+      print "$i/$j: (" . $enclosure->type . ", " . $enclosure->length . ") "  . $enclosure->url . "\n";
+      my $url = $enclosure->url;
+      if($url =~ /^(.*)_cut(\.[^\.]+)$/) {
+        $url = $1 . $2;
+      }
+
+      my $ff = File::Fetch->new(uri => $url);
+      next unless (uc($ff->output_file) =~ $bdfile); # file not from correct day
+
+      my $sum_title = decode_entities($entry->title);
+      my $sum_text = decode_entities($entry->content->body);
+
+      my $current_file = `cat $STAT_FILE`;
+      if($current_file eq $ff->output_file) {
+        print "Already downloaded file of today\n";
+        $dbh->disconnect();
+        exit 0;
+      }
+      $out_file = $ff->output_file;
+      if(!rhimport::check_file_extension($out_file)) {
+        print "\n\nThe extension of the matching file '". $out_file . "' seems to be wrong - manual import necessary!!!\n";
+        $dbh->disconnect();
+        exit 1;
+      }
+
+      print " --> " . $bdfile . ": downloading " . $url . " (" . $enclosure->length . " Bytes) .. ";
+      $file = $ff->fetch( to => '/tmp' ) or die $ff->error;
+      print "ok\n";
+
+      print "summary:\n" . $sum_title . "\n\n" . $sum_text . "\n";
+
+      rhimport::pv_add_note($sum_title, $sum_text, $PV_ID, sprintf("%04d-%02d-%02d", $import_date[0], $import_date[1], $import_date[2]), "1");
+      print "\n";
+
+      last;
+    }
+  }
+  last if $file ne "";
+}
+
+if($file eq "" || !(-e "$file")) {
+  print "No Entry found from $bd or download error - ";
+  if($#ARGV >= 0 && $ARGV[0] eq 'last') {
+    print "giving up, manual import necessary!!!\n";
+  } else {
+    print "will retry later\n";
+  }
+  exit 1;
+}
+
+print "will import $file to dropbox $dropbox (cart=$to_cart)\n";
+
+my $error_cb = sub {
+  my ($text) = @_;
+
+  print "\n$text";
+  return 0;
+};
+
+rhimport::check_key_file() or die "Import Key not found, use rhimport-create-id to create one\n";
+
+my $ret;
+my $log = rhimport::clear_carts($dbh, $group, $to_cart);
+my $import_log;
+($ret, $import_log) = rhimport::import_single($file, $dropbox, $user, 0, $error_cb);
+$log .= $import_log;
+
+$dbh->disconnect();
+
+unlink $file;
+
+if(!$ret) {
+  print "\nImport Error:\n";
+  print $log;
+  exit 1;
+}
+
+unlink($STAT_FILE);
+open(my $fhs, '>', $STAT_FILE);
+print $fhs $out_file;
+close($fhs);
+
+exit 0;
-- 
cgit v0.10.2