summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohannes Raggam <raggam-nl@adm.at>2011-03-26 19:47:27 (GMT)
committerJohannes Raggam <raggam-nl@adm.at>2011-03-26 19:47:27 (GMT)
commit92d2cd54a68f85d92b3bde2c12800c9b1a360641 (patch)
treecf4abaaa6a2500dc51e78e99aa643df4c045f115 /setup.py
parent1f384ccf609e4d8cea4ac15c789d044ab6fa86f7 (diff)
creating an egg pt3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..47852d2
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,33 @@
+from setuptools import setup, find_packages
+import os
+
+version = '0.1'
+
+setup(name='helsinki.program',
+ version=version,
+ description="Program Management for Radio Helsinki, Graz",
+ long_description=open("README.rst").read() + "\n" +
+ open(os.path.join("docs", "CHANGES.rst")).read(),
+ # Get more strings from http://www.python.org/pypi?:action=list_classifiers
+ classifiers=[
+ "Programming Language :: Python",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ ],
+ keywords='django radio',
+ author='Ernesto Rico-Schmidt',
+ author_email='',
+ url='',
+ license='',
+ packages=find_packages(exclude=['ez_setup']),
+ namespace_packages=[],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[
+ 'setuptools',
+ # -*- Extra requirements: -*-
+ 'python-dateutil',
+ ],
+ entry_points="""
+ # -*- Entry points: -*-
+ """,
+ )